× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Hi people having difficulty with with my 2003 mj13a, elm came P0335

More
07 Jan 2019 14:07 - 07 Jan 2019 14:21 #200125 by Scooter
EML light came on when code read on snap on solus P0335 code came up crank shaft sensor replaced camshaft sensor still the same replaced camshaft sensor still the same replaced timing chain still the same replaced starter motor and alternator still the same what it does is you can start it clear the code and it stays off when you restart the code come straight back up again driving me absolute crackers I have checked voltages and those are both crank and cam sensors all good as anybody out there a wiring diagram for the ECU please or any help driving me mad
Last edit: 07 Jan 2019 14:21 by Lambert. Reason: Swearing. Please remember this is a family friendly forum.

Please Log in or Create an account to join the conversation.

More
07 Jan 2019 20:08 #200144 by kbike
"P0335 code came up crank shaft sensor replaced camshaft sensor still the same replaced camshaft sensor still the same "
Is this a"typo",camshaft sensor fault range is P0340-0349.Believe ECU wiring may be in www.suzuki4x4.net/manual/jimny/99512_81A20_015.pdf but looks like it may take time to digest.
You do not have permissions to access this page.
You do not have permissions to access this page.

Please Log in or Create an account to join the conversation.

More
07 Jan 2019 20:12 #200145 by Scooter
Sorry yes. I’ve replaced both crank and cam shaft sensors
I’ll take a look at the ECU wiring link. Thank you. Much appreciated.

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.059 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.