×
Search (23 Feb 2018)

A trial enhanced search facility has been enabled. Please use the Google Custom Search above.

× A place for general chat about the Jimny. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Suppliers/Dealers or anyone selling with a commercial view in mind CANNOT post here unless responding to a specific request of a member in a "wanted" post.

Suppliers include people "breaking for spares" on a regular basis, when purchasing spares members should ask a supplier what they contribute to the running of the forum particularly if contacted by a Private Message

Suppliers or Members who have contributed to the forum can be identifed by the
logo.[/size][/color][/b]

Clutch problem?

More
07 Dec 2018 22:21 #198759 by Mattch5150
Clutch problem? was created by Mattch5150
Hi all the 2005 Jimny is having an issue. When driving in any gear and when pulling off in first it bogs down or sticks and then catches up with itself and goes forward ok. I presume this is likely to be a clutch slipping issue?. Car has done 87000 miles. Brakes not binding and j can't think what else it could be, any ideas?

Please Log in or Create an account to join the conversation.

More
08 Dec 2018 05:26 #198765 by Max Headroom
Replied by Max Headroom on topic Clutch problem?
It does sound like clutch - I just replaced mine for £250 inc VAT with one of the Mr. Clutch workshops.
I only had to apply some slight pressure on the clutch pedal and it would slip. It turned out to be worn down to the rivets


IF IT AINT BROKE, KEEP FIXING IT UNTIL IT IS

Please Log in or Create an account to join the conversation.

  • Busta
  • Busta's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Norfolk's official off-roading God.
More
08 Dec 2018 08:11 #198768 by Busta
Replied by Busta on topic Clutch problem?
Does the engine speed drop when this is happening? Does the pedal action feel smooth?

Please Log in or Create an account to join the conversation.

More
08 Dec 2018 08:34 #198769 by Lambert
Replied by Lambert on topic Clutch problem?
Sounds like a bad clutch. With the engine running engage 5th gear and lift the clutch slowly, if it stalls the engine then the clutch is fine if the engine keeps running then the clutch is bad. That's assuming that the clutch is correctly adjusted via the plastic wheel on the bellhousing.

It's not a Jimny. It's my Jimny

Mooo said Ermintrude (black)
Boing said Zebedee (blue automatic)
Hello said Florence (silver gv 2.4)

Please Log in or Create an account to join the conversation.

More
08 Dec 2018 13:45 #198776 by Mattch5150
Replied by Mattch5150 on topic Clutch problem?
No change in pedal feel but engine speed does drop so can be dodgy when pulling out of a junction for instance

Please Log in or Create an account to join the conversation.

More
14 Dec 2018 17:37 #198955 by Mattch5150
Replied by Mattch5150 on topic Clutch problem?
Thanks for everyone's help on this. The clutch cable was seized. New one on and adjusted fine now. But since returning from garage 4wd light is flashing. Do you think they have left a vacuum pipe off or something. It worked fine yesterday before they did clutch cable.garage Not open until .Monday!!!

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.075 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.