×
BigJimnyMeet (North) 2024 (12 Jan 2024)


BigJimnyMeet 2024

14th July 2024
Parkwood Nr. Leeds

Booking now closed at 148 vehicles!!!



Looking forward to seeing everyone there

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Windscreen washers not working (2007)

More
22 Jun 2024 12:54 #256394 by Forde
Afternoon all. I've been a member for a few months but haven't posted until now. The windscreen washers on my 2007 Jimny stopped working yesterday. The reservoir is full and the pump makes no noise when trying to activate. The wipers still work and I believe they are on the same fuse as the pump. Am I right in my assumption that the pump has probably failed? The rear pump hasn't worked since I bought it a few months ago, so I can't try swapping them over!
Thanks in advance

Please Log in or Create an account to join the conversation.

More
22 Jun 2024 13:11 #256397 by me101
Hi. Remove the plugs off the pumps, clean and refit. Likely a contact issue.

2007 Little Jim with cheap mods!
www.youtube.com/channel/UCeBDekO99Qk2aOmBmSmrI9w
The following user(s) said Thank You: Forde

Please Log in or Create an account to join the conversation.

More
22 Jun 2024 13:47 #256399 by Forde
Thanks. They don't look too bad but will try that first

Please Log in or Create an account to join the conversation.

More
22 Jun 2024 14:07 #256400 by Rogerzilla
Cam you check if there is voltage to the pump?  You might need someone to.operate the washers while you hold a multimeter to the electrical connector.
The following user(s) said Thank You: Forde

Please Log in or Create an account to join the conversation.

More
22 Jun 2024 15:15 #256402 by Forde
They actually just worked, albeit very briefly, so hoping cleaning the contacts will work

Please Log in or Create an account to join the conversation.

  • Lambert
  • Lambert's Avatar
  • Offline
  • Moderator
  • Moderator
    Registered
  • The quickest Jimny in Harrogate...(that I own)
More
22 Jun 2024 16:41 #256404 by Lambert
Also be aware that some of the cheaper washer fluid can congeal into slime that blocks the jets

Temeraire (2018 quasar grey automatic)
One of the last 200ish of the gen3s, probably.
ADOS Attention Deficit Ooooh Shiny!

Please Log in or Create an account to join the conversation.

More
22 Jun 2024 16:59 #256405 by Forde
Thanks. Have only ever used water in my ownership so I don’t think that’s an issue

Please Log in or Create an account to join the conversation.

More
24 Jun 2024 19:08 #256431 by Forde
Cleaning the plugs seems to have resolved this one. Thanks for all the advice

Please Log in or Create an account to join the conversation.

Time to create page: 0.144 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.