×
Grey Pictures! (19 Mar 2017)

Pictures from IPHONES in PORTRAIT mode are coming out grey. Either take the picture in landscape mode or upload to a sharing site such as Photobucket or use a picture editor to remove the EXIF data.

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Jimny hot running issues...

More
12 Oct 2017 19:25 #185145 by mark98
mark98 created the topic: Jimny hot running issues...
Long time no post...I do still have my Jimny, but in more recent months it plagued by consistent but irritating hot running. Only runs hot at speed (over 65-75, any less and its totally fine), when off road at slow speed and when idling for extended periods. It can be controlled and will run all day fine if the heater is turned up to the max and blasting at full speed. I have tried to remedy this several times. It has had in the past 12 months a new head gasket, new rad, new thermostat and just last week a new water pump. I'm starting tow wonder if its really worth continuing to pour money into this problem. I am seriously considering selling it if I can't sort this hot running our once and for all. I do not really want to do this, as I have spent lots of time and money on my Jimny over the past 2 years, but I am getting sick of pouring in money to not get results. I've been told that the viscous fan could be not working effectively, is there anything else worth checking/changing before I take the route of selling it? Any advice really is appreciated...
Attachments:

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 19:44 #185147 by Keithy
Keithy replied the topic: Jimny hot running issues...
Travelling at speed the viscous fan wouldn't be engaged....unless you have too little airflow through the radiator.

If turning the heater on makes the overheating manageable then you have a lack of liquid flow through the radiator, lack of airflow....headgasket failure or a cracked head......or a lying temperature gauge/sender.....test for each and you're done....you get 45 minutes to check it all out....or you're sacked! :D

Please Log in or Create an account to join the conversation.

More
12 Oct 2017 19:47 #185148 by mark98
mark98 replied the topic: Jimny hot running issues...
Cheers...hows best to check the temp gauge isn't lying to me? If its been that all along then there will be a very Basil Fawlty style moment...

Please Log in or Create an account to join the conversation.

More
13 Oct 2017 10:11 #185163 by Keithy
Keithy replied the topic: Jimny hot running issues...
Thermometer....I have a contact one.....must get myself a non contact one. also check the thermostat.......the heater circuit works independent of the thermostat.

Please Log in or Create an account to join the conversation.

More
13 Oct 2017 10:48 #185168 by mlines
mlines replied the topic: Jimny hot running issues...
To check the viscous fan, get the vehicle up to the point where you consider it "hot" and then stick a rolled up newspaper into the fan blades. If it shreds the newspaper, your fingers and your arm then it is fine. If the newspaper stalls the fan then it is stuffed.

Martin

Martin

2003 M13 early KAP build.
3" Trailmaster lift with 1.5 Spacers on front
Customised winch bumper and roll cage
235/85R16 Maxxis Bighorns on 16" Rims, 4:1 Rocklobster, Rear ARB locker and on-board air
Corrected arms all-round, rear disks, Recaro seats and harnesses
The following user(s) said Thank You: mark98

Please Log in or Create an account to join the conversation.

More
13 Oct 2017 16:35 #185179 by Keithy
Keithy replied the topic: Jimny hot running issues...
And remember....halfway up the forearm counts as zero! :D

Please Log in or Create an account to join the conversation.

More
13 Oct 2017 17:44 #185184 by mark98
mark98 replied the topic: Jimny hot running issues...
Mr Lines...you were correct...newspaper stalled the fan almost immediately. I assumes this is the part to replace? -

Please Log in or Create an account to join the conversation.

More
13 Oct 2017 19:29 #185189 by mlines
mlines replied the topic: Re:Jimny hot running issues...
Yes that's the right one. As long as you are confident that the car was really hot so the fan should be locked the that sounds like the issue

Sent from my Nexus 6P using Tapatalk

Martin

2003 M13 early KAP build.
3" Trailmaster lift with 1.5 Spacers on front
Customised winch bumper and roll cage
235/85R16 Maxxis Bighorns on 16" Rims, 4:1 Rocklobster, Rear ARB locker and on-board air
Corrected arms all-round, rear disks, Recaro seats and harnesses

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.569 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.