×
Vehicles (17 Jan 2019)

You can now add the vehicles you own to your profile as little icons that appear in your profile and alongside your posts.
This is a bit of an experiment. Take a look under the "REWARDS" menu across the top of the screen for the vehicles "ADD/MODIFY" option.
Let me know how you get on.

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Revs dropping on idle

  • happypig
  • Topic Author
  • Visitor
  • Visitor
    Public
03 Dec 2012 18:35 #54759 by happypig
Revs dropping on idle was created by happypig
Last couple of days I've developed an intermittent problem whereby the revs sometimes drop when idling, usually when pulling up to a junction or parking.
Any ideas before I get my garage to have a look ?

Please Log in or Create an account to join the conversation.

  • Licksan
  • Visitor
  • Visitor
    Public
03 Dec 2012 18:45 #54760 by Licksan
Replied by Licksan on topic Revs dropping on idle
Had the same symptoms and turned out to be a broken throttle position sensor.

Replaced it and all was good again.

You can unplug it and the engine will run. Maybe not optimally but should stop it stalling.

Please Log in or Create an account to join the conversation.

  • happypig
  • Topic Author
  • Visitor
  • Visitor
    Public
03 Dec 2012 20:01 #54769 by happypig
Replied by happypig on topic Revs dropping on idle
Cheers for that, could be it as I was poking about yesterday fitting air horns.
Whereabouts is the sensor?

Sent from my Nexus 7 using Tapatalk 2

Please Log in or Create an account to join the conversation.

  • suzuki jimny fella
  • Visitor
  • Visitor
    Public
03 Dec 2012 20:21 #54770 by suzuki jimny fella
Replied by suzuki jimny fella on topic Revs dropping on idle
i have had this problem a few time would like to no what it is pic would be awsome it have not done it for a while touch wood whats the worst that can happen guys

Please Log in or Create an account to join the conversation.

  • Licksan
  • Visitor
  • Visitor
    Public
03 Dec 2012 21:38 - 03 Dec 2012 21:39 #54785 by Licksan
Replied by Licksan on topic Revs dropping on idle
The TPS is fitted to the Throttle Body.

If your facing the car front on it's on the right hand side of the throttle body between the head/cam cover and above the inlet manifold. Has a black connector fitted with 3 wires to it. Will take a pic tomorrow.

Some people have indicated the wiring can be at fault and there is a way to test it but in my opiniom its most likely the sensor on its way out. I think the fact the Jimny can be a tad bumpy makes your foot bounce about on the throttle pedal which prematurely wears out the tracks on the PCB in the TPS causing an irratic signal to be sent to the ECU which upsets the idle.

www.bigjimny.com/index.php/forum/7-jimny...tion-sensor-tps-m13a
Last edit: 03 Dec 2012 21:39 by Licksan.

Please Log in or Create an account to join the conversation.

  • Licksan
  • Visitor
  • Visitor
    Public
04 Dec 2012 15:13 #54814 by Licksan
Replied by Licksan on topic Revs dropping on idle
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.123 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.