×
BigJimnyMeet (North) 2024 (12 Jan 2024)


BigJimnyMeet 2024

14th July 2024
Parkwood Nr. Leeds

Booking now closed at 148 vehicles!!!



Looking forward to seeing everyone there

× A place for more technical discussions. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

ABS light after instrument cluster replacement - Car does not have ABS!!

More
11 Jun 2024 02:30 #256250 by Whiskeyjack
Hi Guys,
I am slowly working through the growing list of problems that my ’05 Jimny has, and this one flummoxed me.. I just today received a replacement dash instrument cluster from a wreckers to replace mine which had a problem where the engine light, oil light and ABS light were dead, but the brake light was on all the time.
The new cluster comes from a slightly newer jimny however was completely identical otherwise and plugged/screwed straight into the car.
When I turn the engine on now, I am seeing the engine light (expected, EGR fault) but also the ABS light is on. The problem here is that my car (as far as I can tell) does not have ABS. There is no ABS module in the engine bay, and despite smashing the brakes as hard as I could on an e-stop test I couldn’t trigger the ABS (or lock the wheels which is slightly concerning). 

Is there anything I can do to get the ABS warning light to turn off????

One of the upgrades I want to do is to put disc brakes on the rear using the kit from the jimny store and the Renault Megane calipers. Am I right in thinking this should be fine without ABS???

Please Log in or Create an account to join the conversation.

  • Lambert
  • Lambert's Avatar
  • Offline
  • Moderator
  • Moderator
    Registered
  • The quickest Jimny in Harrogate...(that I own)
More
11 Jun 2024 03:23 #256251 by Lambert
I'm trying to picture the back of the cluster? I assume you have done a side by side examination with your old one to compare bulb positions? Abs was only an option then. The fool proof way is to look at the inside of the wheel hubs for sensor wiring.

Temeraire (2018 quasar grey automatic)
One of the last 200ish of the gen3s, probably.
ADOS Attention Deficit Ooooh Shiny!

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 03:58 #256252 by Whiskeyjack
THanks for your reply.
The two units were pin perfect matches, and I have also double checked that the old one had the ABS light in the module, even though it did not turn on.
There is definitely no ABS on the vehicle as there is no ABS control module under the hood, abs control lines or ABS sensor wiring…

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 06:27 - 11 Jun 2024 08:09 #256255 by Whiskeyjack
It’s interesting that even though the ABS hardware isn’t in the vehicle, all the computers for the ABS are in there. This probably means that it’s doing brake light checks on vehicle start and if the previous owner had changed them to LED bulbs and not put the resistors in parallel that the brake light fault is being triggered. Unfortunatey I ony have a basic OBD reader so cannot access ABS controller stuff. I can see other controllers on the OBD line, but have no info what the values are…

EDIT: What I thought was the ABS computer diagnostic port was just a blue relay… So there is no ABS and no ABS computer...
Last edit: 11 Jun 2024 08:09 by Whiskeyjack.

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 06:43 #256256 by Whiskeyjack
Ok scratch that idea. Just opened up the brake light and other than some of the sketchiest wiring I have _ever_ seen, the bulbs are definitely an incandescent type… Anyone have any clues as to what else the ABS monitors?

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 07:12 #256257 by Rogerzilla
If your car doesn't have ABS, I see no issue with removing the bulb.  MOT testers won't check the warning light works on a car that was clearly built without ABS.

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 08:06 #256259 by Whiskeyjack
It’s more that I don’t want the light on… Vehicle is already roadworthy.

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 08:08 #256261 by Whiskeyjack
Also what I thought was the ABS test port (without glasses on) was just a blue relay… so there really isn’t an ABS module.

I was wondering if the instrument panel might have its own CPU inside which is expecting an ABS module and lighting up because there isn’t one there, but surely it’s just a dumb panel...

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 08:38 #256262 by Whiskeyjack
Hmm ok seems there _is_ a CPU on the dash instruments… 

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 08:47 #256263 by Whiskeyjack
I think I have found a solution - it involves putting a smalll piece of tape over the ABS light.

The worst type of hack, but perfect for this car...
The following user(s) said Thank You: Darthblaker7474

Please Log in or Create an account to join the conversation.

Time to create page: 0.173 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.

We use cookies to give you the best online experience. Please let us know if you agree to all of these cookies. Accepting the Cookies also accepts the Disclaimers for the website.