×
BigJimny Meet 2019 (17 May 2019)

BigJimny Meet and off-road driving day



20TH OCTOBER 2019

NOW BOOKING - CLICK HERE


See HERE for details - See HERE for discussion

× A place for general chat about the Jimny. Please make sure you post in the correct section on the site, this way it keeps the site tidy AND ensures you get a more relevant answer.

Suppliers/Dealers or anyone selling with a commercial view in mind CANNOT post here unless responding to a specific request of a member in a "wanted" post.

Suppliers include people "breaking for spares" on a regular basis, when purchasing spares members should ask a supplier what they contribute to the running of the forum particularly if contacted by a Private Message

Suppliers or Members who have contributed to the forum can be identifed by the
logo.[/size][/color][/b]

Power steering belt 1.3 vvt 2005 non air con manual

  • Mattch5150
  • Topic Author
  • Visitor
  • Visitor
    Public
17 Jul 2018 15:42 - 17 Jul 2018 16:04 #194389 by Mattch5150
Hi all , tried to change the alternator and ps belts today. Used guides from here. Removed radiator etc. I could not undo the bolts on the power steering tensioner. Snapped two sockets trying. Had to give up and reassemble. Any ideas as am struggling with this
Cheers
Matt
Last edit: 17 Jul 2018 16:04 by Mattch5150.

Please Log in or Create an account to join the conversation.

  • Lambert
  • Lambert's Avatar
  • Online
  • Moderator
  • Moderator
    Registered
  • The quickest Jimny in Harrogate...(that I own)
  • Posts: 3933
  • Thank you received: 654
  • Points: 6085.00
  • Gen 3 Jimny GV (2010) Gen 3 Jimny
17 Jul 2018 17:44 #194399 by Lambert
First off if you are snapping sockets that doesn't say much for the quality of the sockets. Second even with some galvanic corrosion they shouldn't be that tight. Plenty of wd40 or other preferred product left overnight and then try to tighten them a little first before gentle application of the 18 inch breaker bar should have them off easy enough.

Dreadnaught (black 2011)

Please Log in or Create an account to join the conversation.

  • Mattch5150
  • Topic Author
  • Visitor
  • Visitor
    Public
17 Jul 2018 19:00 #194407 by Mattch5150
Thanks. These are the 2 12mm bolts. They would not budge. I've done many things on the car but this maybe out of my league I suppose. Thanks anyway

Please Log in or Create an account to join the conversation.

  • Lambert
  • Lambert's Avatar
  • Online
  • Moderator
  • Moderator
    Registered
  • The quickest Jimny in Harrogate...(that I own)
  • Posts: 3933
  • Thank you received: 654
  • Points: 6085.00
  • Gen 3 Jimny GV (2010) Gen 3 Jimny
18 Jul 2018 04:06 #194411 by Lambert
Where abouts in the country are you, someone local with some notice might be able to take a look for you?

Dreadnaught (black 2011)

Please Log in or Create an account to join the conversation.

  • Mattch5150
  • Topic Author
  • Visitor
  • Visitor
    Public
18 Jul 2018 08:37 #194413 by Mattch5150
I'm in Alcester Warwickshire near stratford on avon

Please Log in or Create an account to join the conversation.

  • Mattch5150
  • Topic Author
  • Visitor
  • Visitor
    Public
12 Aug 2018 17:30 #195055 by Mattch5150
I've put a new radiator in and changed both belts breaker bar helped!. However after 3 wks ps belt had a split. It turns out I put 833 on the ps and the 850 on the alternator.trying to get the too.small ps belt on must have cut it on edge of pulley. One of the how to.posts on site had alternator as 850 and ps as 833. My alternator belt , the old one had no markings on it. Anyway I have put a new ps 850 belt on. The alternator belt is still 850 so 1.7 cm bigger but i tensioned it more than it was on 833 there was a goid 2 to 3cm more of tension to go and it seems to be ok and all working well and has 90 degree flex on longest run. We live and learn. Ive had the radiator out 4 times now on thst bas***d!

Please Log in or Create an account to join the conversation.

  • Busta
  • Busta's Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
    Registered
  • Norfolk's official off-roading God.
  • Posts: 2564
  • Thank you received: 494
  • Points: 424.00
13 Aug 2018 12:10 #195084 by Busta
Yes PS needs to be 850 and the alternator is 833 (or 830?) but has plenty of adjustment so you can run an 850 on both. Then you only need to keep one spare belt!

Please Log in or Create an account to join the conversation.

Moderators: funkyjimnyooky_123
Time to create page: 0.057 seconds
Powered by Kunena Forum

I hope you enjoy using this forum. Please consider making a donation towards the upkeep of this forum website.